ソース検索 | 設計書自動作成ソフト「Trinity」

ソース検索

ソース検索

IBM i(AS/400)から転送したメンバーソースに対してキーワード検索を行う機能です。Trinityの分析ツールで対象が見つからない場合やオブジェクトに関連する情報を検索したい場合に利用します。

初めに[キーワード検索]ボタンをクリックします。

キーワード検索画面が表示されますので検索条件などを設定します。

設定の詳細についてはマニュアルを参照してください。条件の設定が完了したら[開始]ボタンをクリックします。検索中は経過を示すダイアログが表示されます。検索が終わると一覧と実際のコードが表示されます。

一覧のカーソル行を移動すると、表示されているコードも切り替わります。

メニューの「ファイル」→「エクスポート」を選択します。ダイアログが表示されますので、ファイル名やファイルの種類を選択して[保存]ボタンをクリックします。

なおファイルの種類には以下3種類があります。

OOXMLファイルでエクスポートを行うと、シンプルながらもセルへの色付けや罫線が引かれた状態でExcelブックが作成されますので、簡易的な資料としてすぐに活用いただけます。

「サマリー」とは、検索で見つかったソースに含まれるキーワード件数のことで、例えばキーワードの含まれたソースが全体でどのくらいあるかを調べる場合、具体的な場所の情報は不要になりますので、サマリー表示を行う方が見通しの良い結果が得られます。

サマリー表示に切り替えるには[キーワード検索]ボタンの横にある「サマリーを表示する。」をチェックします。

複数のフォルダを同時に検索したい場合、「;(セミコロン)」で区切って指定します。

なお[参照]ボタンでフォルダを照会する場合はカーソルのあるフォルダが対象になります。

検索結果を元に絞り込み検索を行うには「検索リスト」を使用します。

編集エリアの左横ボタンをクリックすることで「検索パス」「検索リスト」の表示を切り替えることができますので、「検索リスト」に切り替えます。

「検索リスト」は検索対象となるファイル名を1行1ファイルとして保管したテキスト形式のファイルです。テキスト形式なので様々な方法で作成できますが、検索結果を元に作成することで絞り込み検索を行うことができます。

ここではCLおよびPRGソースについて「CXFILE」を検索して、結果から検索リストを作成してみます。まずは検索を行います。

検索結果が表示されたらメニューの[ファイル]→[検索リストの作成]をクリックします。ダイアログが表示されますので、任意のフォルダに検索リストを保管します。

先ほど作成した検索リストを元にフィールド名の絞り込み検索を行います。[キーワード検索]の画面を開きます。検索対象を[検索リスト]に変更し、照会ボタンをクリックして先ほど保管した検索リスト(CXFILE.TXT)を設定します。

続いて「検索文字列」にフィールド名を入力して[開始]ボタンをクリックして検索を行います。検索リストを使用したため、先ほど検索したCXFILEを含むソースだけを対象に検索が行われます。

オブジェクト辞書を作成している場合、検索結果にオブジェクト情報を付加することができます。

オプション設定の[翻訳対象情報保管先][オブジェクト情報を出力する。]をチェックすることで検索結果にオブジェクト情報が付加されます。

フィールドネットでも同様の検索を行えますが、ここではファイル検索を使った場合の手順を解説します。

手順としては通常の検索と同じですが、検索条件の設定方法に3つのポイントがあります。

1.検索文字列にはファイル名とフィールド名の両方を設定します。
2.「範囲」で「ファイル」を選択します。
3.「AND条件で検索する。」をチェックします。

特に2.は複数キーワードを含むソースを検索する際には必要な設定になりますので、覚えておくとよいでしょう。

検索対象を[設計書フォルダ]に変更します。続いて検索を行いたい設計書フォルダを選択します。

続いて[対象種別]タブをクリックして切り替えます。[対象種別]のリストが表示されますので、対象外にしたいファイル種別を右側の[対象外種別]のリストに移動します。

複数選択を行うにはファイル種別をCtrl キーやShift キーを押しながらマウスの左ボタンでクリックします。サンプル画面ではRPG ソースのファイル種別以外を選択して[対象外種別]のリストに移動しようとしています。

選択が完了したら[>]ボタンをクリックして選択した種別を[対象外種別]のリストに移動します。

[対象種別]のリストが検索対象にしたいファイル種別のみになっていることを確認したら[開始]ボタンをクリックします。

対象にしたいファイル種別が[対象外種別]のリストに含まれる場合、ファイル種別を選択して[<]ボタンをクリックすることで[対象種別]のリストに移動することができます。

「ソース検索辞書」を使用すると通常の方法よりも短時間でソース検索を行うことができます。なおこの操作を行うにはあらかじめ「言語翻訳」「ソース検索辞書」を作成しておく必要があります。

検索対象を[設計書フォルダ]に変更します。続いて検索を行いたい設計書フォルダを選択します。

続いて[検索にソース検索辞書を使用する。]をチェックしてから検索を行います。

なおソース検索辞書を使用して検索する場合、[範囲]「行」が設定されたものとして処理されます。 また開始位置や終了位置を指定できますが、漢字も1文字としてカウントされますので使用する際にはそれらを踏まえて使用して下さい。