グループ設計

グループ設計

言語翻訳で翻訳した設計書を閲覧するための画面です。翻訳された設計書はデータとして作成されるため、そのままではイメージとして閲覧できません。 「グループ設計」を使用することで、初めてイメージとして閲覧できます。

グループ設計の起動方法には以下の2つの方法があります。

■言語翻訳から起動する。
1.言語翻訳画面で[編集/印刷]ボタンをクリックします。
2.グループ設計が起動します。

■メニューから起動する。
1.メニューから[グループ設計]を選択します。
2.グループ設計が起動します。
3.メニューの[ファイル][翻訳結果(RPG)][現在の設定ファイル]を選択して翻訳結果を表示します。

前者では自動的に翻訳結果が表示されるため、後者のようにわざわざ翻訳結果を選択する必要がありません。しかし後者では言語翻訳を起動する必要が無いので、閲覧だけ行いたい場合に手早く作業をはじめることができます。

画面左側のライブラリとファイルの一覧から閲覧したいFILEをダブルクリックします。

選択されたファイル内のメンバーが一覧で表示されますので、任意のメンバーを選択してダブルクリックします。

選択されたメンバーについて作成された設計書の一覧が表示されます。

このように任意のファイルやメンバーをダブルクリックすることで設計書の一覧が表示できます。ダブルクリックの代わりにCtrl+エンターキーを使用することもできます。

グループ設計では各階層を個別のファイルとして管理しており、そのファイルを「グループファイル」と呼んでいます。画面下部には現在表示中のグループファイル名がタブ形式で表示されています。クリックすることでグループファイルを簡単に切り替えることができます。

続いて画面から任意の設計書を選択して[表示]ボタンをクリックすると設計書が表示されます。

表示された設計書は表示倍率を変更したり、ページを移動したり、印刷することができます。詳しくはマニュアルを参照してください。

設計書ではなくメンバー名(フォルダ)を選択してから[表示]ボタンをクリックします。

グループ設計ではメンバー名やファイル名などの「フォルダ」を選択することで、そこに含まれる設計書をまとめて閲覧することができます。

なお誤ってライブラリーなどを表示してしまうと物凄く時間がかかることになりますので注意して下さい。もちろん中止は行えます。

管理資料は専用の「管理資料」フォルダにまとめて保管されています。一覧の最後にある「管理資料」をダブルクリックします。

管理資料の一覧が表示されますので任意の設計書を閲覧してください。

グループ設計で閲覧するシステムを切り替えるには、メニューの「ファイル」→「翻訳結果(RPG)」から閲覧したいシステム(グループ)を選択します。 サブメニューに言語翻訳で作成した設定の名前が一覧で表示されますので、閲覧したい設定を選択して表示します。

画面左上の「しおり」を使用することで表示中の設計書を切り替えることができます。

「しおり」には関連する設計書もまとめて表示されます。

設計書上の任意のテキストに「マーキング(色付け)」が行えます。検索機能の代用としても利用できます。

マーキングを行うにはメニューの[マーキング]→[マーキング]をクリックします。

「マーキング」ダイアログが表示されますので、キーワードを入力して[検索]ボタンをクリックします。

設計書上のキーワードを含むテキストがマーキングされて(ここでは赤色)で表示されます。なお次のマーキングされたテキストのあるページに移動するにはF4キーを押します。


表示中の設計書に画面/帳票レイアウトが含まれる場合、「マーキング」ダイアログのインターフェイスが変わります。 これはマーキング対象のフィールドが画面/帳票レイアウトに含まれる場合、レイアウト上の「XXXXX」や「99/99/99」などのフィールドのテキストもマーキングするための設定項目が増えています。

各項目の内容は以下の通りです。

なおフィールドのテキストに対するマーキングは、罫線で囲ったりパターンで範囲を覆うような効果で表現されます。

設計書上のプログラム名やファイル名などのテキストから関連するメンバーの設計書を表示することができます。

設計書上のテキストをマウスの右ボタンでクリックすると「関連情報」ダイアログが表示されます。

クリックされたテキストに関連付けられた設計書が存在する場合、一覧にメンバー名が表示されますので、選択してから[関連資料の表示]ボタンをクリックすることで設計書が表示されます。

見つからない場合は「キーワード」を変更してから[一覧更新]ボタンをクリックすることで入力されたキーワードを元に関連する設計書の一覧が更新されます。

なお関連する設計書を表示する場合、グループファイル閲覧専用の外部プログラム「グループ設計書の表示(ZDGroupViewer.EXE)」が使用されます。

「グループ設計書の表示」では「グループ設計」で設計書を閲覧する際に使用できる全ての機能に加えて、複数のグループファイルをタブで切り替えながら閲覧を行うことができます。そのため「グループ設計書の表示」で関連する設計書の表示を行うと、その設計書は閲覧に使用されている画面に新しいタブとして追加されていきます。

クリックされたテキストが画面や帳票レイアウトのフィールドの場合、属性や桁数と言ったフィールド情報を確認できます。

導入されているライセンスによっては「キーワード」を元に「フィールドネット」「変数ネット」を呼び出すこともできます。閲覧中の設計書から手軽に分析ツールと連携を取ることができます。

メニューの「表示」→「メンバーソースの表示」をクリックすると、表示中の設計書に関連付けられたメンバーソースを表示します。

メンバーソースの表示には、通常はシステムでテキストファイルに関連付けられたアプリが使用されますが、「RPGソース日本語化」が使用できる場合、RPGソースは「RPGソース日本語化」を使って表示されます。

一度表示した設計書をキャッシュすることで次回の表示にかかる時間を短縮できます。

メニューの「ファイル」→「オプション」をクリックしてオプション設定を表示します。

表示されたら[全体設定]タブ「表示された設計書をキャッシュする。」をチェックすることで設計書をキャッシュできるようになります。あとは[更新]ボタンをクリックして設定を確定して下さい。

メニューの「表示」→「キャッシュされた設計書の削除」をクリックします。

画面が表示されたら[検索]ボタンをクリックします。確認のメッセージが表示されますので[はい]をクリックします。

検索結果が表示されたらスペースキーやHOMEキーを使って削除したいキャッシュを選択して[削除]ボタンをクリックします。確認のメッセージが表示されますので、削除しても良ければ[はい]をクリックしてキャッシュを削除します。

なおこの画面では「検索文字列」を使った内容の絞り込みが行えます。詳しくはマニュアルを参照して下さい。

「原紙名称」を変更することで設計書のイメージ(見え方)を変更することができます。

補足:原紙とは?
設計書のひな型もしくはフォーマットのことで、設計書のデータをどのようなイメージとして表示するかを定義したものです。

設計書はイメージとして保管されているわけではなく、データとして保管されており、閲覧時に原紙を元にイメージとして展開されます。そのため原紙を変更すると閲覧時のイメージを変更することができます。

[参照]ボタンをクリックします。

原紙名称の選択画面が表示されますので、変更したい原紙名称を選択して[決定]ボタンをクリックします。

これで原紙が変更されました。[表示]ボタンをクリックして、設計書のイメージが変わったことを確認して下さい。

なお今回は閲覧時に原紙を変更する手順について解説しましたが、翻訳時の原紙については「言語翻訳」で設定します。詳しくはマニュアルを参照してください。

画面DDSや帳票DDSなど、複数のレコードを組み合わせてひとつのレイアウトを作成するものについては、Trinityが基本的な組み合わせを自動的に行います。しかし内容によっては上手く組み合わせができない場合もあります。このような場合には手作業で組み合わせを変更することができます。

画面DDSの設計書の一覧を表示して「画面定義書」を選択します。次に[組合]ボタンをクリックして[画面/帳票の組み合わせ]画面を表示します。

この画面でページ毎に表示されるレコードの組み合わせを設定します。もちろんページの追加や削除も行えますし、レコードの繰り返し数などを設定することで設計書としての体裁を整えることもできます。また使い方によっては画面遷移図的なものを作ることもできるでしょう。詳しい操作方法についてはマニュアルを参照してください。

変更したい設計書を選択して[編集]ボタンをクリックします。

「ファイル設計」が表示されました。この画面では翻訳結果を表形式の画面で編集することができます。

サンプルの「セグメント構成図」は階層構成のデータなので「階層」の値によって親子関係が作られます。サンプルでは子供の階層を追加しています。

変更した内容を保管するには[保管]ボタンをクリックします。終わったら画面右上の「×」ボタンでファイル設計を終了します。

グループ設計の画面で[表示]ボタンをクリックして変更結果を確認します。

まとめたい設計書が含まれるグループファイルを開きます。

メニューの「検索」→「設計書の検索」をクリックします。

画面が表示されたら検索条件を設定します。ここでは例として画面定義書を検索するための条件を設定してみます。

テキスト項目は選択後にエンターキーを押すことで照会もしくは直接入力が行えます。条件の設定が終わったら[検索]ボタンをクリックして検索を実行します。

検索中は結果が一覧形式で表示されます。終わったら画面右下の[保管]ボタンをクリックして、結果をグループファイルとして保管します。

保管されたグループファイルは新しいタブとして追加されただけなので、ファイルとして保管したい場合には画面左上の[保管]ボタンをクリックします。

ファイルの保管ダイアログが表示されますので、保管先フォルダやグループファイル名を設定して保管します。